DebianLinux 배포판 기반의 Linux. LinuxDesktop으로 괜찮다고들 함.

http://www.ubuntulinux.org http://www.ubuntu.or.kr

주요정보

관련기사

UbuntuLinux 설치후, 해야하는 일들. (2005-06)

특별관리가 필요한 패키지들

패키지관련명령

apt-cache search 패키지명 (패키지검색, RegularExpression)
apt-cache show 패키지명
apt-get install 패키지명
apt-get remove 패키지명
echo '패키지명 hold' | dpkg --set-selections (패키지 hold)
echo '패키지명 install' | dpkg --set-selections (패키지 hold 해제)
dpkg --get-selections | grep hold (hold 된 패키지 보기) 

백포트리스트

deb http://archive.ubuntu.com/ubuntu hoary-backports main universe multiverse restricted

한국미러

deb http://kr.archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb http://kr.archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb http://kr.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb http://kr.archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse


예전에 fedora core를 쓸때도, rpm 같은것에는 관심이 없었던터라, 데비안의 패키징이 어떤건지 잘 몰랐었다. apt-get 저 한 명령으로, 그 어렵고 짜증났던, Trac, SCGI설치가 한방에 되더만. 이래서 좋은거였군. --yong27, 2005-06-14

데비안 패키징이 안되어 있는 Python 패키지를 설치하려면? 일단, 그냥 소스를 받아다가 setup.py 를 실행하면 다음의 에러 발생.

yong27@bhn:~/pkg/zodb/ZODB3-3.2.9$ python setup.py build
running build
running build_py
running build_ext
error: invalid Python installation: unable to open /usr/lib/python2.4/config/Makefile (No such file or directory)
yong27@bhn:~/pkg/zodb/ZODB3-3.2.9$

뭔가 따로 데비안패키지를 위한 패키징 방법이 있을 것 같은데 찾아봐도 관련정보가... 일단은 비슷한곳. Debian python policy

  • 허걱... python-dev 를 설치하니까 되는군. ㅡ.ㅡ; 그나저나, 패키징방법은 여전히 궁금하다. -- yong27 2005-07-10 07:41:08

아.. 우분투의 아파트 가져오기 명령은 참 강력해 보이는군요 -- cyppi 2005-09-08 15:30:09


몇주 전에 패키지관리자에서 mozilla-firefox와 mozilla-firefox-gnome-support를 update시키는 에러가 계속나서 그냥 썼었는데, 오늘은 아예 firefox가 시작되지 않는 상황이 발생하였다. 대략 error내용을 읽어보면 dpkg에서 설치하는데 문제가 있다고 나옴. firefox install의 문제점 해결방법.

apt-get remove --purge mozilla-firefox mozilla-firefox-gnome-support

sudo rm -rf /usr/lib/mozilla-firefox
sudo rm -rf /etc/mozilla-firefox

apt-get install mozilla-firefox mozilla-firefox-gnome-support


만약 software가 upgrade되었는 데, 기존의 버젼으로 사용을 해야 할 경우나 Downgrade가 필요한 경우

aptitude install <package name>=<version>

ADSL을 사용할 경우엔 달랑

apt-get install pppoeconf
pppoeconf

Bhn: UbuntuLinux (last edited 2012-06-12 11:10:57 by yong27)

web biohackers.net